[Haskell] Re: Trying to install binary-0.4

Simon Marlow simonmarhaskell at gmail.com
Thu Oct 25 06:03:13 EDT 2007

Duncan and I have started a wiki page to collect proposals for ways to 
avoid or alleviate the pain from future package reorganisations.


It's been helpful for me to write all this down, the issues seem much 
clearer.  However, I don't see an obviously best solution.  For me proposal 
4.2 (see the wiki page) looks the most promising, but it doesn't provide 
complete backwards compatibility, so I imagine there will be people who 

Please read the page.  Fix problems, add rationale, add proposals if you 
have any that are substantially different from those already there.  For 
general discussion just reply to this message (replies directed to 
libraries at haskell.org).


More information about the Libraries mailing list