[Haskell] Re: Trying to install binary-0.4

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Thu Oct 18 18:53:46 EDT 2007

On Wed, 2007-10-17 at 20:28 +0100, Ian Lynagh wrote:
> On Wed, Oct 17, 2007 at 01:28:45AM +0100, Duncan Coutts wrote:
> > On Wed, 2007-10-17 at 00:35 +0100, Ian Lynagh wrote:

> > > might be a type error if I have multiple versions of foo installed and
> > > bar and baz have been compiled against different versions.
> > 
> > Sure, those are not compatible. But we can detect that just by looking
> > at the dependencies of each package.
> In general it is possible to have 2 different versions of a package in a
> single program, though, e.g. bar and baz could internally use different
> versions of a binary-tree package.

Right, but only if those packages are used privately, ie such that types
from the dependent packages do not leak into their public api, since
that would allow the type error you originally pointed out. If we
distinguish private use of a dependent package then we know it does not
matter if we end up using two versions of it in a single program.


More information about the Libraries mailing list