Trying to install binary-0.4

Johan Tibell johan.tibell at
Wed Oct 10 09:03:28 EDT 2007

In the latest version of GHC (6.8) the base library was split up into
many smaller libraries. Among them containers. Your problem is
probably related to that. I don't have my Haskell setup nearby
unfortunately so I can't tell you exactly what the problem is.

-- Johan

On 10/10/07, Paul Johnson <paul at> wrote:
> In my copious free time I'm putting together a client-side library for
> AMQP.  This needs efficient packing of bytestrings, so I downloaded
> Dons' bytestring 0.4.  Unfortunately it won't install: I get
> [paj at eiffel binary-0.4]$ ./Setup.lhs configure
> Configuring binary-0.4...
> configure: Dependency base-any: using base-2.1.1
> Setup.lhs: cannot satisfy dependency containers-any
> Should this be "collections" not "containers"?  I can't find a
> "containers" package in Hackage.
> Paul.
> _______________________________________________
> Libraries mailing list
> Libraries at

More information about the Libraries mailing list