cabal ignores ld-options?

Duncan Coutts duncan.coutts at
Mon Apr 23 19:20:26 EDT 2007

On Mon, 2007-04-23 at 16:09 -0700, Stefan O'Rear wrote:

> IIRC yhc uses the Posix dynamic linker/loader infrastructure, so it
> needs .so not .o. 

Right, that's fair enough.

> > > Not that Cabal actually supports nhc98 yet...
> > 
> > We'll gladly accept patches :-)
> stefan at stefans:~/vty$ ./Setup.lhs configure --help | grep nhc
>   -n       --nhc                           compile with NHC
> stefan at stefans:~/vty$
> If cabal doesn't support NHC, why does it advertise support?

Don't ask me I'm just a cabal patch monkey :-). Perhaps I shouldn't
admit it but I've never personally tried cabal with nhc. I should
probably fix the nhc gentoo ebuild and try it some time.


More information about the Libraries mailing list