Proposal: reduce base from the top
bulat.ziganshin at gmail.com
Tue Apr 3 08:31:56 EDT 2007
Tuesday, April 3, 2007, 3:42:31 PM, you wrote:
>> --> fps (dep. on base, generics, array)
> I think this should be called bytestring; fps will just be a random
> string to newcomers to Haskell.
>> Data.Foldable, Data.Traversable
>> Data.Map, Data.IntMap, Data.Set, Data.IntSet
>> Data.Sequence, Data.Tree
>> ---> new package collections? containers? or split further?
>> (dep. on array, generics, concurrent)
> I assume you give "containers" as an option because I used it in #710,
> but I think I prefer "collections" myself.
Collections is the name of another existing library ;)
>> ---> new package getopt? consoleutils?
thhis may be joined with filesystem-related stuff into one package.
how about having Unix and Win32 for low-level OS-specific functions
and then OS_Services on top of them?
Bulat mailto:Bulat.Ziganshin at gmail.com
More information about the Libraries