Proposal [Trac #1212]: add IPv6 support to network library

Sven Panne sven.panne at
Tue Apr 3 04:52:04 EDT 2007

On Tuesday 03 April 2007 09:18, Bryan O'Sullivan wrote:
> I've updated both the ticket and repo with the latest change, to use
> lists instead of bitmasks.  I left flag names as AI_FOO etc due to name
> clashes. [...]

Naming entities always has a slightly religious touch, but personally I don't 
like those C names in Haskell. Prefixing things in C is only necessary 
because you basically don't have any control over namespaces, but Haskell is 
quite different from it. 'NumericHost' looks much nicer and Haskell-like 
than 'AI_NUMERICHOST', and even in the unlikely case that there is a name 
clash, one could always use qualification. Anyway, the constructors 
of 'Family' have traditionally ugly names, too, so perhaps to keep 
the "consistency of unattractiveness", I can live with the 'AI_' and 'NI_' 
prefixes... :-P

BTW, what's that' DummySocketOption__' thingy? If I see things correctly, you 
can't use it with {g,s}etSocketOption and it has no other visible use.


More information about the Libraries mailing list