4th Cabal-1.1.6 release candiate

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Mon Oct 9 13:59:05 EDT 2006

On Mon, 2006-10-09 at 12:33 +0100, Malcolm Wallace wrote:
> Duncan Coutts <duncan.coutts at worc.ox.ac.uk> wrote:
> > building the haddock docs for HUnit when cpphs is
> > installed fails. This is because the
> > Distribution.PreProcess.Unlit.unlit code produces incorrect output for
> > Test/HUnit/Lang.lhs.
> > 
> > I could do with some help in fixing this.
> You could try using the --unlit option of cpphs,

That sounds like a good plan.

> which gives correct output, instead of the broken code in
> Distribution.PreProcess.Unlit.unlit.

I think the Distribution.PreProcess.Unlit module was taken from an early
version of cpphs. One possibility would be to update to the latest cpphs
unlit code, but for that of course we'd need your permission as the
copyright licenses are different.

> This requires cpphs >= 1.2, which was released in May this year.

Is there anyway to identify the cpphs version from running it? I don't
see any --version flag or similar. I'm wondering how cabal is going to
be able to identify if the user has a sufficiently recent version.


More information about the Libraries mailing list