robdockins at fastmail.fm
Fri Mar 3 10:58:31 EST 2006
The second release candidate for Edison 1.2 is now ready for
comments. The notable changes from RC1 are:
* add strict variants of all folds and reduces
* reverse argument orders to 'rcons' and 'lookup*' in
* Add symbolic operators for lcons, rcons, append, and lookup
from the Sequence API
* Add symbolic operators for subsetEq, difference, intersection
and union from the set API
* rename 'single' to 'singleton' in all APIs
* rename 'intersect' to 'intersection' in Collection and
Associated Collection APIs
* add 'adjustOrInsert' to the Associated Collection API
004952.html for a use case)
And the following are the remaining major issues I'd like to get
-- Edison defines 'subset' and 'subsetEq' in the set API. Data.Set
has operations with the
same meanings named 'isProperSubsetOf' and 'isSubsetOf'. I am
considering adoping the
Data.Set names, but they are quite a bit longer. Also what about
the meaning of "subset"
vs "proper subset"? What do you find most intuitive?
-- Data.Map defines 'isSubmapOfBy' and 'isProperSubmapBy'. Edison
has no corresponding
API methods. Are they important enough to add?
-- What do you think about the symbolic operators? Is the fact that
(++) clashes with the Prelude a problem?
Should the operators be folded into the "Data.Edison" module
In addition, I'm interested in any API related feedback you might have.
Code and docs can be found at the project website:
Or you can go directly to the haddock docs:
Or the darcs repo:
Speak softly and drive a Sherman tank.
Laugh hard; it's a long way to the bank.
More information about the Libraries