Cabal and hIDE

Simon Marlow simonmar at
Tue Nov 29 05:43:00 EST 2005

On 29 November 2005 10:35, Bernd Brassel wrote:

> Hello there,
> I try to install hIDE by cabal, but I got some problems.
> First of all, it seems that I need a newer version of cabal than what
> is shipped with ghc 6.4.1. According to the README of Cabal, 1.1.3 I
> unregistered the older cabal first. But then I get lots of warnings
> the like:
>  > Distribution/Simple.hs:432:25:
>  >     Warning: This binding for `pkg_descr' shadows an existing
>  binding >              In the definition of `mockPP'
>  >
> Is this okay? Or should I have uninstalled something else (and how)?
> Trying to use the new cabal to install hIDE, "runhaskell Setup.lhs
> configure" runs without error, but then:
>  > runhaskell Setup.lhs build
>  > Preprocessing executables for hIDE-0.1.0...
>  > Building hIDE-0.1.0...
>  > ghc-6.4.1: ghc-6.4.1: panic! (the `impossible' happened, GHC
> version 
> 6.4.1):
>  >         unknown exception
>  >
>  > Please report it as a compiler bug to
>  > glasgow-haskell-bugs at,
>  > or
> I guess, something went wrong, didn't it?...

You probably have another package that depends on the old version of
Cabal, and since you unregistered it the dependencies aren't satisfied.
The error message is a bug in GHC 6.4.1 (now fixed), it should read
something like "package Cabal-1.0 not found".

A common package that depends on Cabal is hs-plugins; remove this an
re-install it after removing Cabal-1.0 and you'll be fine.


More information about the Libraries mailing list