Cabal Problem

Russell, Daniel J djrussell at
Mon Nov 7 13:24:39 EST 2005


I am trying to install the Haskell Crypto package using Cabal. 

I have a problem when using Cabal. I have installed NewBinary-0.1 but when trying to configure the Crypto library using


Setup.exe configure --prefix=h:\NewHaXml 


I receive the message:


Configuring Crypto-2.0.3...

configure: Dependency base-any: using base-1.0

configure: Dependency mtl-any: using mtl-1.0

configure: Dependency QuickCheck-any: using QuickCheck-1.0

configure: Dependency HUnit-any: using HUnit-1.1

Setup.exe: cannot satisfy dependency NewBinary-any


This suggests that a NewBinary package does not exist but ghc-pkg list returns:



    Cabal-1.1.4, NewBinary-0.1


Any suggestions?


Many thanks.


Dan Russell

This email has been scanned for all viruses by the MessageLabs Email
Security System.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Libraries mailing list