[Haskell] RFC: DData in hierarchical libraries

Christian Maeder maeder at tzi.de
Thu Mar 11 18:40:29 EST 2004

Ketil Malde wrote:
> I think ascending is the most intuitive order, so how about something
> like:
>         toList  (ascending)


> and     toListReversed (descending)

No, the next one then wants fromDescList and fromDistinctDescList
(or fromReversedList). Let users reverse their lists.

Maybe even (the current) "fromAscList" is not really necessary, because 
toList only produces proper distinct ascending lists.(Thus 
fromDistinctAscList can be renamed to fromAscList.)


More information about the Libraries mailing list