[Haskell] RFC: DData in hierarchical libraries

Ketil Malde ketil+haskell at ii.uib.no
Thu Mar 11 17:22:16 EST 2004

Daan Leijen <daanleijen at xs4all.nl> writes:

> You are right! Indeed, for a proper abstraction, we should specify
> the order...  hmm, that means we need to reconsider either the
> naming scheme (that is, remove toAscList and call it toList) or
> specify explicitly the order that is returned right now.

I think ascending is the most intuitive order, so how about something
        toList  (ascending)
and     toListReversed (descending)

If I haven't seen further, it is by standing in the footprints of giants

More information about the Libraries mailing list