[jhc] JHC fails to build with ghc 7.0.3

Robert Clausecker fuzxxl at gmail.com
Mon May 2 22:08:48 CEST 2011

Am Sonntag, den 01.05.2011, 23:31 -0700 schrieb John Meacham:
> On Sat, Apr 30, 2011 at 7:29 AM, Robert Clausecker <fuzxxl at gmail.com> wrote:
> > I recently upgraded my development platform to GHC 7.0.3 and the latest
> > platform. After manually patching the cabal package for DrIFT (it had a
> > dependency base<4 which was not satisfiable on my system, so I changed
> > it to base-all)  I tried to build jhc.  Both version 0.7.7 fail to
> > build, but there are different reasons:
> I have not tried to use 7.03 yet. Good to know about the Type Families
> issue. Hmm.. that is strange. what version of DrIFT are you using? You
> should be using at least 2.2.3.
> http://repetae.net/computer/haskell/DrIFT/drop/
>    John

I used the cabalized version of DrIFT before, but installed your version
now, to test whether it makes any difference. My installation of DrIFT
is the most recent version. If you are interested, this is how I
configured the program, curiously, the --with-hcflags flag is useless,
so I patched the code by hand (at line 52 of "Makefile.am", I added
"-XTypeFamilies" at the end):

   ./configure --prefix=$HOME/usr

my Haskell toolchain is installed in $HOME/usr, because I don't want to
destroy my system using experimental software.

I guess, the problem is, that some of the core libraries changed their

    Yours, Robert Clausecker

More information about the jhc mailing list