[jhc] JHC fails to build with ghc 7.0.3

John Meacham john at repetae.net
Mon May 2 08:31:29 CEST 2011

On Sat, Apr 30, 2011 at 7:29 AM, Robert Clausecker <fuzxxl at gmail.com> wrote:
> I recently upgraded my development platform to GHC 7.0.3 and the latest
> platform. After manually patching the cabal package for DrIFT (it had a
> dependency base<4 which was not satisfiable on my system, so I changed
> it to base-all)  I tried to build jhc.  Both version 0.7.7 fail to
> build, but there are different reasons:

I have not tried to use 7.03 yet. Good to know about the Type Families
issue. Hmm.. that is strange. what version of DrIFT are you using? You
should be using at least 2.2.3.


More information about the jhc mailing list