[Haskell] ANN: Yi 0.6.2.2
jwlato at gmail.com
Thu Mar 25 08:48:20 EDT 2010
> From: Jeff Wheeler <jeff at nokrev.com>
> On Wed, Mar 24, 2010 at 2:27 PM, Colin Paul Adams
> <colin at colina.demon.co.uk> wrote:
>> Hm. I edited the cabal file to allow >= 2.3 && < 2.5 and it just
>> compiled. Wouldn't this work with 6.12 also?
> Unfortunately not. Making that change yields:
> yi$ cabal install
> Resolving dependencies...
> cabal: dependencies conflict: ghc-6.12.1 requires template-haskell ==18.104.22.168
> template-haskell-22.214.171.124 was excluded because data-accessor-template-0.2.1.3
> requires template-haskell >=2.2 && <2.4
> data-accessor-template needs to be compiled with the -ftemplate_2_4
> flag, which Cabal doesn't try here, for some reason.
Will it work if you set data-accessor-template < 0.2.1.3 in the .cabal
file? I think that version is acceptable to both ghc-6.10 and 6.12.
More information about the Haskell