[Haskell] hsc2hs can't find gcc under windows

Curt Sampson cjs at starling-software.com
Thu Dec 25 01:17:38 EST 2008

I'm trying to upgrade from ghc 6.8.3 to 6.10.1. Unfortunately, there
seem to be problems with the Windows version. (I've installed it on
two different machines, both Windows XP, and they've both had the same
problem. Both worked fine with 6.8.3.)

When I run hsc2hs, on an hsc file, I get the error, "Can't find gcc".

Just as an experiment, I tried adding c:\ghc\ghc-6.10.1 to my path. That
lets it find gcc, but then it can't find cc1. If I go even further down
this road and add c:\ghc\ghc-6.10.1\gcc-lib to my path, it can find cc1,
but then I get a stream of errors about not being able to find header
files, such as HsFFI.h.

Does anybody have any clues here to help me? I can provide code, or even
access to the machine, if needed. We're also happy to pay for support,
if someone out there is offering commercial support for ghc.

Curt Sampson       <cjs at starling-software.com>        +81 90 7737 2974
           Functional programming in all senses of the word:

More information about the Haskell mailing list