[Haskell] Re: Trying to install binary-0.4

Udo Stenzel u.stenzel at web.de
Fri Oct 12 04:45:28 EDT 2007

Udo Stenzel wrote:
> - install exactly one version of cabal,, and *remove* all
>   others,
> - ask ghc-pkg for the description of base, then edit Data.ByteString out
>   of that and re-register it,

I forgot, I also tried tar-1.0 on GHC 6.6, and had the same problem
there.  Even after updating Cabal, there was no way to install
'bytestring' due to the conflict with 'base'.  A modified package
description for 'base' helped.

The reason that tar absolutely wants new stuff is 'instance MonadFix
Get', which is not in binary-0.3.  If you absolutely want users of GHC
6.6 to stick with binary-0.3, then you should provide a maintenance
release binary-0.3.1.  And we're back to Eternal Compatibility in

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://www.haskell.org/pipermail/haskell/attachments/20071012/87153243/attachment-0001.bin

More information about the Haskell mailing list