[Haskell] Re: ANNOUNCE: GHC version 6.8.2

Gregory Wright gwright at comcast.net
Thu Dec 20 15:00:11 EST 2007


On Dec 20, 2007, at 2:31 PM, Hugo Pacheco wrote:

> >From the ghc-6.8.2 sources then, I'm just afraid of possible  
> errors, and I don't have any previous ghc installed.
> Do the sources permit bootstrapping? From what I know...
> The source distribution needs an installed GHC (version 6.0 at  
> least). If your platform isn't currently supported with a binary  
> distribution, then you'll need to consult the section on Porting GHC  
> in the Building Guide.
> I'm afraid of the same error as macports 6.6.1:
> configure: error: GHC is required unless bootstrapping from .hc files.

The macports 6.8.2 should be ready soon for Tiger (PPC and Intel) and  
Leopard (Intel only).
I have had successful builds on these platforms and the Portfile is  
updated.  However,
the 6.8 branch seems to have introduced a bug in file locking (#1992  
in the trac) that
causes the build to fail once out of every four or five times.  This  
is not acceptable for
a production release, so this has to be tracked down before GHC from  
macports is

Sorry for the delay,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell/attachments/20071220/a4ec38b7/attachment.htm

More information about the Haskell mailing list