[Haskell-cafe] HsOpenSSL doesn't build

fr33domlover fr33domlover at riseup.net
Sun Feb 25 08:49:10 UTC 2018

Oh and I do have `libssl-dev` installed from distro package.

On Sun, 25 Feb 2018 09:47:35 +0200
fr33domlover <fr33domlover at riseup.net> wrote:

> Hello Haskellers,
> For a long time I did my Haskell coding on a laptop running Trisquel 7
> GNU/Linux, 64-bit. I had stack installed from FPComplete's debian
> repo, and GHC 7.10.3 installed from hvr's PPA. I was working, among
> other things, on a program that I built last time with LTS 6.5 and
> everything was okay.
> Then I moved to a new laptop, now I run Devuan Jessie (which is
> basically the same as Debian 8 Jessie), 64-bit, and I have stack
> installed using the script provided by the stack website, and GHC
> installed using `stack setup`. I'm trying to build the very same
> program, and I get this:
>     Configuring HsOpenSSL-
>     Cabal-simple_mPHDZzAJ_2.0.1.1_ghc-7.10.3: Missing dependencies on
>     foreign libraries:
>     * Missing C libraries: crypto, ssl
>     This problem can usually be solved by installing the system
>     packages that provide these libraries (you may need the "-dev"
>     versions). If the libraries are already installed but in a
>     non-standard location then you can use the flags
>     --extra-include-dirs= and --extra-lib-dirs= to specify where they
>     are.
> I thought maybe my OpenSSL version is too old. That's a bit weird
> because it seems to be more recent than the Trisquel one (well,
> basically same version, just some micro version being a bit higher),
> but still, I decided to try a few things:
> - I installed OpenSSL 1.1 using Guix and used the flags mentioned
> above to point to Guix's include and dir paths
> - I downloaded OpenSSL 1.1 release tarball, built from source,
>   installed, pointed stack to that location
> - In those extra dirs I listed all the system ones like /lib
>   and /usr/lib just in case
> - I updated stack to the latest release, and did stack setup
>   --upgrade-cabal and installed alex and happy because stack
> complained no package was providing them
> - I deleted .stack-work and ~/.stack and did a totally clean build
> But nothing works, I'm still getting this error. On the older laptop
> everything works.
> How do I go about solving this? I don't know what else to try or how
> to make `stack build` look in the paths I provide and see the OpenSSL
> library there and use it.
> Thanks in advance for any clues!!!
> --
> fr33
> _______________________________________________
> Haskell-Cafe mailing list
> To (un)subscribe, modify options or view archives go to:
> http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
> Only members subscribed via the mailman list are allowed to post.

More information about the Haskell-Cafe mailing list