[Haskell-cafe] trying to build Hackage hoq-0.3

Vasili I. Galchin vigalchin at gmail.com
Mon Jan 25 07:22:27 UTC 2016

1) ghc version 7.6.3

2) cabal version

3) when i run "cabal install",

       I receive on stdout :

Resolving dependencies...
Configuring readline-
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for GNUreadline.framework... checking for readline... no
checking for tputs in -lncurses... no
checking for tputs in -ltermcap... no
checking for tputs in -lcurses... no
checking for rl_readline_version... no
configure: error: readline not found, so this package cannot be built
See `config.log' for more details.
Failed to install readline-
cabal: Error: some packages failed to install:
hoq-0.3 depends on readline- which failed to install.
readline- failed during the configure step. The exception was:
ExitFailure 1

4) I googled Haskell and readline and I found the same error with
other Haskell packages like Twitter.

How do I resolve my build  readline problem?


More information about the Haskell-Cafe mailing list