[Haskell-cafe] Haskell, stack and the Atom editor

Thomas Koster tkoster at gmail.com
Sat Apr 9 07:03:10 UTC 2016

Hi friends,

I want to switch to the Atom editor for my Haskell development. I have
tried several times over the last few years and given up each time because
hardly anything works.

I can't stand Emacs so don't bother suggesting it.

I am currently using Geany, which has served me well, mostly because it is
dead simple so nothing can go wrong. In addition to the usual universal
text editor functions, all it does is highlight syntax (albeit with an
outdated grammar), runs custom commands to build, displays clickable errors
in a separate pane and underlines them in the editor pane. But for larger
projects, I want more (better autocompletion, better integration with the
build system, better VCS support).

But back to Atom, I am having extreme difficulty getting even the basics

I am using GHC 7.10.2, Cabal, Stack 1.0.4.

I installed Atom 1.6.1 from their deb package.

I installed the "language-haskell" package. This works very well,
thankfully, but is the *only* thing that I can get working.

I avoided "ide-haskell", even though it looks great, because their readme
says it can't build with stack and I rely heavily on stack.

Instead, I installed the "build" and "linter" packages and created an
".atom-build" file to build my project with stack. It invokes stack
correctly, but I can't get it to recognise any errors: linter always says
"No issues". I must have tried twenty different regexes in "errorMatch" but
none of them seem to work.

I also installed "linter-hdevtools", hoping that that may let me see some
errors, but I can't get that to work either. The package is loaded but it
appears to do absolutely nothing. strace does show that Atom is trying to
exec hdevtools through stack, but I get no output at all within Atom as
evidence that something worked or failed.

hdevtools appears to have its own problems. I had installed hdevtools
( with stack:
    stack install hdevtools
I ran it myself using:
    stack exec --no-ghc-package-path hdevtools -- check Main.hs
and it gives me the infamous error:
    Cabal error: Use of GHC's environment variable GHC_PACKAGE_PATH is
    incompatible with Cabal.
This is strange because "stack exec --no-ghc-package-path env" reports that
no such environment variable is defined, as expected.

At this point I am ready to give up yet again. Does anybody have any
last-minute advice on using Atom to develop with Haskell and Stack?

Thomas Koster
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20160409/fdfa50a7/attachment.html>

More information about the Haskell-Cafe mailing list