[Haskell-cafe] an idea for modifiyng data/newtype syntax: use `::=` instead of `=`

Kosyrev Serge _deepfire at feelingofgreen.ru
Sat Aug 8 21:33:41 UTC 2015

Brandon Allbery <allbery.b at gmail.com> writes:
> On Sat, Aug 8, 2015 at 5:21 PM, Kosyrev Serge <_deepfire at feelingofgreen.ru> wrote:
>     I don't mean to come across argumentative -- rather I merely want to point
>     out,
>     that the way of accomplishing it in a non-breaking way was proposed in this
>     thread:
>     an extra keyword + a pragma to guard against name clashes.
> Not worth the fact that I now have to look for two effectively incompatible
> languages both calling themselves Haskell.

Do you mean that adding a new keyword to the language, guarded by a
language extension, really deserves this strong wording -- "effectively incompatible"?

What about the precedents?

 - TransformListComp: group, by, using
 - RecursiveDo: mdo, rec

Then, I guess there was a number of keywords introduced by Haskell 2010.

Косырев Серёга
“And those who were seen dancing were thought to be insane
 by those who could not hear the music.”
 – Friedrich Wilhelm Nietzsche

More information about the Haskell-Cafe mailing list