[Haskell-cafe] compiling GHC 7.8 on raspberry pi

Sven Bartscher sven.bartscher at weltraumschlangen.de
Sun Apr 19 14:15:15 UTC 2015


I'm trying to get a haskell program to run on a raspberry pi (running
raspbian). Unfortunately it requires template haskell.
Since the GHC included in raspbian wheezy doesn't support TH I'm trying
to compile GHC 7.8.4 on the rpi.
Most of the compilation worked fine. I got problems with the memory
consumption, but adding a lot of swapspace solved this problem.
During the final phase the compilation process complains about a
"strange closure type 49200" (the exact number is varying, but most
often it's 49200).
Does anyone here have experience, how to compile GHC 7.8 on a raspberry

As a side note: The compilation is running in QEMU while the compiled
program should run on a real rpi.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: Digitale Signatur von OpenPGP
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20150419/ca2a78c9/attachment.sig>

More information about the Haskell-Cafe mailing list