[Haskell-cafe] 2014 haskell cabal update hangs on mac

Madhu Babu madhub.bits at gmail.com
Tue Aug 26 23:58:20 UTC 2014

You are right. It worked for me now. Earlier, i deleted only
/Library/Hashell, ~/.cabal & one more similar dir. Looks like there are lot
of directories ( & more importantly broken symlinks which were still
pointing to old Library ).

Once i deleted all of them, it worked.

Thanks again for the advice.

On Tue, Aug 26, 2014 at 4:23 PM, S D Swierstra <doaitse.swierstra at gmail.com>

> I suffered from the same phenomenon. I carefully removed everything which
> smelled of ghc, including .ghc in my home directory and many spurious
> aliases. That cured the problem,
>  Doaitse
> On 26 Aug 2014, at 6:51 , Madhu Babu <madhub.bits at gmail.com> wrote:
> I initially installed haskell platform ( 2013 version; 7.6.3 ghc ) on my
> mac. Everything was working great. Just now saw the haskell platform
> website again and found new version was released ( Haskell Platform
> 2014.2.0.0 for Mac OS X, 64bit ). I installed it, and un-installed the
> older version using uninstall-hs.
> Now when i type "cabal" or "cabal update" on my terminal, it hangs.
> Actually when i look into Activity Monitor, i can see that it is invoking
> some "sh script & possibly some find command" infinitely. I initially guess
> may be it is building some indexes. but it has been running for an hr or so.
> I have Xcode 5, gcc and other command line tools installed properly
> Please advice. I cannot install any other package using cabal.
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20140826/6f6b406a/attachment.html>

More information about the Haskell-Cafe mailing list