[Haskell-cafe] Name for the following combinators?
hans at hanshoglund.se
Sat Dec 28 15:47:40 UTC 2013
Recently I have found myself using these two combinators a lot: http://lpaste.net/97643
They basically allow composition of any m satisfying (Monad m, Traversable m). I have been thinking about moving them to a separate package and giving them better names (in the original paper, they are simply called join and bind).
Does anyone have a better suggestion for the name of the package, module and the two combinators? Should they be called joinDefault, or simply called join and bind to be imported with a qualifier? This might be a bicycle-shed question, but I tend to find stylistic questions important when it comes to improving clarity and readability.
More information about the Haskell-Cafe