[Haskell-cafe] Alternative name for return

Erik Hesselink hesselink at gmail.com
Tue Aug 6 09:50:35 CEST 2013

What about `pure`? It's already used in applicative, and has the
motivation that it's embedding a pure value in some context. Since I
don't know the details of your project, I don't know if you need two
names (one for the applicative version, and one for the monadic


On Tue, Aug 6, 2013 at 7:14 AM, J. Stutterheim <j.stutterheim at me.com> wrote:
> Dear Cafe,
> Suppose we now have the opportunity to change the name of the `return` function in Monad, what would be a "better"  name for it? (for some definition of better)
> N.B. I am _not_ proposing that we actually change the name of `return`. I do currently have the opportunity to pick names for common functions in a non-Haskell related project, so I was wondering if there perhaps is a better name for `return`.
> - Jurriën
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list