[Haskell-cafe] Alternative name for return

Christian Sternagel c.sternagel at gmail.com
Tue Aug 6 07:32:19 CEST 2013

Dear Jurriën.

personally, I like "lift" (which is of course already occupied in 
Haskell), since an arbitrary value is "lifted" into a monad. (The 
literature sometimes uses "unit".)



On 08/06/2013 02:14 PM, J. Stutterheim wrote:
> Dear Cafe,
> Suppose we now have the opportunity to change the name of the `return` function in Monad, what would be a "better"  name for it? (for some definition of better)
> N.B. I am _not_ proposing that we actually change the name of `return`. I do currently have the opportunity to pick names for common functions in a non-Haskell related project, so I was wondering if there perhaps is a better name for `return`.
> - Jurriën
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list