[Haskell-cafe] Alternative name for return
j.stutterheim at me.com
Tue Aug 6 07:14:56 CEST 2013
Suppose we now have the opportunity to change the name of the `return` function in Monad, what would be a "better" name for it? (for some definition of better)
N.B. I am _not_ proposing that we actually change the name of `return`. I do currently have the opportunity to pick names for common functions in a non-Haskell related project, so I was wondering if there perhaps is a better name for `return`.
More information about the Haskell-Cafe