[Haskell-cafe] cabal install... Trying to recover

Gregory Guthrie guthrie at mum.edu
Wed Nov 21 18:06:57 CET 2012

OK; I took HTTP out, but still get the same error;
    cabal: The following packages are likely to be broken by the reinstalls:
    Use --force-reinstalls if you want to install anyway.

One thing I notice;
Ghc reports: G:\Cabal>ghc --version
     The Glorious Glasgow Haskell Compilation System, version 7.4.2

But I did notice that I had an environment variable (from some previous install, I think openCV?) of:
So I updated that to 7.4.2
And retried, same results.

But then, ghc-pkg check reports:
   The following packages are broken, either because they have a problem
   listed above, or because they depend on a broken package.

I have no idea where the 2012.2 comes from.
Any suggestions?

From: Brandon Allbery [mailto:allbery.b at gmail.com]
Subject: Re: [Haskell-cafe] cabal install... Trying to recover

So I split it into sections, and tried the first one; it lists a lot of new installs, and then fails
  (full list at http://pastebin.com/5ywdUjgX)

You're explicitly asking it for a new version of HTTP, which is asking for trouble.

More worrisome is that it's still asking for new versions of base, which means it's still confused about what version of ghc is installed.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20121121/dacd2b66/attachment.htm>

More information about the Haskell-Cafe mailing list