[Haskell-cafe] Hackage dependencies problem.

Magicloud Magiclouds magicloud.magiclouds at gmail.com
Wed Nov 21 05:18:07 CET 2012

But I think it should be like this, right?
Say ghc provids process-old, and Cabal-old depends on it. Then I use
--upgrade-dependencies to install somePackage and so install process-new in
user space. The process-old is still there. Why Cabal-old breaks and
`ghc-pkg check` gets nothing?

On Wed, Nov 21, 2012 at 8:47 AM, Albert Y. C. Lai <trebla at vex.net> wrote:

> On 12-11-19 09:39 PM, Magicloud Magiclouds wrote:
>> And, the key point is that using upgrade-dependencies with
>> cabal-install. I am using git (current) version of cabal-install.
>> Without that argument, things could be fine. With it, it must fail.
> Therefore, don't use upgrade-dependencies.
> ______________________________**_________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/**mailman/listinfo/haskell-cafe<http://www.haskell.org/mailman/listinfo/haskell-cafe>


And for G+, please use magiclouds#gmail.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20121121/aaef93c4/attachment.htm>

More information about the Haskell-Cafe mailing list