[Haskell-cafe] Again, version conflicting problem with cabal-install
magicloud.magiclouds at gmail.com
Wed May 2 08:47:56 CEST 2012
Hi, long time no see.
I am using cabal-install-0.15.0. And the new solver. It sure solves
some problem. Thanks for the work.
Well, on the other hand, there still are hackages that I just have no
idea how the author make it (probably not up-to-date hackage
database). After human-solver checking, these hackages are not be able
to build at all under certain conditions.
So, I am voting on the "force-allow" flag.
On Sat, Feb 4, 2012 at 12:36 AM, Andres Löh <andres.loeh at googlemail.com> wrote:
>>> with the semantics that all dependencies on foo will be changed to
>>> allow foo-1.3 to be chosen. Would that be ok? Other suggestions?
>> Can't this be integrated with the current --constraint flag?
> It could be, but ...
>> If the
>> constraint is able to be satisfied without unrestricting any bounds,
>> fine. Otherwise, unrestrict any bounds on that constraint. What
>> would be the drawbacks?
> ... it shouldn't happen automatically. There are perfectly valid and
> safe reasons to use --constraint, whereas this new feature is
> inherently unsafe. But allowing general constraint syntax and calling
> the flag something with "constraint" in it is perhaps a good idea.
>> An advantage is being able to specify --constraint='foo >= 1.3' to get
>> foo-220.127.116.11 instead of having to find out exactly which version you
>> want. And if you already know what you want, you may always say
>> --constraint='foo == 18.104.22.168'.
>> Looking forward to the new solver! =)
> I need testers and feedback. You can already use it. It's in the
> cabal-install development version, and can be enabled by saying
> --solver=modular on the command line.
And for G+, please use magiclouds#gmail.com.
More information about the Haskell-Cafe