[Haskell-cafe] The State of Testing?

Christoph Breitkopf chbreitkopf at googlemail.com
Fri Feb 10 08:08:52 CET 2012

On Thu, Feb 9, 2012 at 6:57 PM, Thomas Tuegel <ttuegel at gmail.com> wrote:

> You need Cabal 1.12 for '--enable-library-coverage'. The only place
> it's documented is in 'cabal configure --help' (a major oversight on
> my part). The online docs for Cabal are only from version 1.10 anyway,
> so that wouldn't have helped.
> I'm sorry for your struggles getting the detailed type to work. It's a
> known issue: the detailed test interface is intentionally disabled in
> all the released versions because it's going to change. That's why
> none of the test libraries support it yet and why you weren't able to
> get it to work.
No problem - I was just wondering where my error lay. The stdio tests do
the trick for the time being.

- Chris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20120210/51e079eb/attachment.htm>

More information about the Haskell-Cafe mailing list