[Haskell-cafe] Type error when trying to adapt http-proxy to new conduit

Michael Snoyman michael at snoyman.com
Thu Dec 27 09:27:18 CET 2012

On Thu, Dec 27, 2012 at 9:42 AM, Erik de Castro Lopo
<mle+hs at mega-nerd.com>wrote:

> Pieter Laeremans wrote:
> > Hi,
> >
> > The http-proxy package isn't  compatible any longer with the latest
> > conduit. Since it is open source, I thought, I might as well try to adapt
> > it and submit a patch.
> Have you looked int git?
> It currently compiles from git but there is a space leak that
> I haven't managed to fix yet.
> Erik
> --
> ----------------------------------------------------------------------
> Erik de Castro Lopo
> http://www.mega-nerd.com/
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

Hi Erik,

I remember discussing very briefly with you why it wasn't possible to
simply use warp as a library for this project. I wonder if there would be a
way to expose more functionality from warp to make the maintenance burden
easier for http-proxy going forward. I'll be on IRC in a bit if you'd like
to discuss it.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20121227/0632750d/attachment.htm>

More information about the Haskell-Cafe mailing list