[Haskell-cafe] Error in cabal install of monad-par?

Rishiyur Nikhil nikhil at acm.org
Thu Sep 15 20:01:23 CEST 2011

Apropos my previous request for help (below): I think I've managed to
diagnose it and fix it myself.

It looks like I had a previous version of ghc installed (using 'port install
ghc', which installed 6.10.x in /opt/local/bin/.
The Haskell Platform seems to install 7.0.3, in /usr/bin/.
Looks like cabal was invoking the older ghc due it being earlier in my PATH.
Fixed, and it installs ok now.

Thanks anyway,


On Thu, Sep 15, 2011 at 12:29 PM, Rishiyur Nikhil <nikhil at acm.org> wrote:

> I'm following the instructions on the CUFP "T5 Parallel Programming in
> Haskell"  web page for preparing for the tutorial, where it asks that I
> should:  'cabal install monad-par'.
> I'm doing this on a Mac, Snow Leopard 10.6.8, after installing Haskell
> Platform.
> I have Xcode 3.2.4 installed.
> I get the following error; please let me know how I should fix it (can
> reply to me personally instead of the list, at 'nikhil at acm dot org'.
> Thanks.
> Nikhil
> $ cabal install monad-par
> Resolving dependencies...
> Configuring monad-par-
> Preprocessing library monad-par-
> Building monad-par-
> Control/Monad/Par/Internal.hs:4:15-71:
>     unknown flag in  {-# OPTIONS #-} pragma: -fno-warn-unused-do-bind
> cabal: Error: some packages failed to install:
> monad-par- failed during the building phase. The exception was:
> ExitFailure 1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20110915/dc1427ff/attachment.htm>

More information about the Haskell-Cafe mailing list