[Haskell-cafe] Problems with installing the correct version of "process". Help?

Blaine frikker at gmail.com
Tue Nov 15 23:56:57 CET 2011

So this is hilarious. This whole time I thought 'warning' meant 'error'.

I rebuilt all of ghc and the platform with 7.0.3, and did it again. Now it
complains about containers.

Went ahead and installed anyway (duh!). Now it looks like it worked. I'll
check back if it didn't work.

I can't believe I never tried to just install the darn thing...

On Tue, Nov 15, 2011 at 5:04 PM, Daniel Fischer <
daniel.is.fischer at googlemail.com> wrote:

> On Tuesday 15 November 2011, 22:34:17, Blaine wrote:
> > Great question. How does one ignore the warning?
> Not.
> process and directory are boot packages, required by ghc  and indirectly by
> many of the packages you install(ed).
> Having multiple versions of these spells trouble and breakage.
> Read http://www.vex.net/~trebla/haskell/sicp.xhtml for more.
> You already have two versions of directory, the one ghc was built with and
> It's not unlikely that you already have some unusable packages due
> to that.
> $ ghc-pkg check
> should tell you about such.
> You should unregister the duplicate directory (, *keep the one ghc
> was built with*) and all packages depending on it.
> Then you can try to reinstall those packages, before cabal installing
> anything, you should check with --dry-run whether it would install a new
> version of any of the boot packages (basically everything coming with ghc
> itself, but having a newer version of Cabal is okay). If it would, stop.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20111115/e768e4af/attachment.htm>

More information about the Haskell-Cafe mailing list