[Haskell-cafe] GHC 7/Cabal request for help

John Goerzen jgoerzen at complete.org
Thu Mar 24 21:41:26 CET 2011

On 03/24/2011 11:30 AM, Erik Hesselink wrote:
> I've just tested this, and with GHC 7, cabal chooses QuickCheck 2.4,
> whereas with GHC 6.12, it chooses 2.1. If I specify that 6.12 should
> choose 2.4 as well, I get the same issue there. This is to be
> expected, because I don't see the CPP checks you mentioned in
> Test/QuickCheck/Instances.hs in testpack-2.0.1. Perhaps you haven't
> released a version with those checks yet?

Well that would be embarrassing...  but that may indeed be the case.  My 
git tree is marked as if it's released, but apparently it's not.  Sigh. 
  My red-faced apologies for the noise.

-- John

More information about the Haskell-Cafe mailing list