[Haskell-cafe] Installation of Haskell Platform on CentOS 5.5

Tristan Ravitch travitch at cs.wisc.edu
Fri Mar 18 15:40:43 CET 2011

On Fri, Mar 18, 2011 at 08:23:10AM +0100, Ketil Malde wrote:
> Tristan Ravitch <travitch at cs.wisc.edu> writes:
> > The ghc7 binaries are compiled against a newer version of glibc than
> > is available on RHEL/CentOS.  It works fine if you compile ghc7 from
> > source yourself (you can use 6.12 for that).
> Did it?  I tried to do that, but I got errors about needing -fPIC.  I
> tried to mess with CFLAGS, but couldn't make it work out.  According to
> somebody on #haskell (I apologize for forgetting whom), the problem was
> really a too old GCC version.

Now that you mention it, I did have to switch to a newer gcc for the
x86_64 build.  I ended up using 4.5.  That part is annoying;  I wasn't
able to coax the default 4.1.2+patches into generating correct
position-independent code either.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20110318/4bf8b434/attachment.pgp>

More information about the Haskell-Cafe mailing list