[Haskell-cafe] Installation of Haskell Platform on CentOS 5.5

frode k mailinglist at klevstul.com
Fri Mar 18 09:06:22 CET 2011

*** GHC 7

> The ghc7 binaries are compiled against a newer version of glibc than
> is available on RHEL/CentOS.  It works fine if you compile ghc7 from
> source yourself (you can use 6.12 for that).

| Did it?  I tried to do that, but I got errors about needing -fPIC.  I
| tried to mess with CFLAGS, but couldn't make it work out.  According to
| somebody on #haskell (I apologize for forgetting whom), the problem was
| really a too old GCC version.

It's a shame it's so hard to setup Haskell on CentOS. I guess compiling GHC
7 from source takes a lot of time (?). It would be nice to know if anyone at
all has managed.


> Building
> "/usr/haskell-platform-2010.2.0.0/bin/ghc" "--make" "Setup" "-o" "Setup"
> "-package" "Cabal-"
> Linking Setup ...
> collect2: ld terminated with signal 15 [Terminated]

> Error:
> Compiling the Setup script failed
> make: *** [build.stamp] Error 2

Does anyone know why the Haskell Platform won't install though? 2010.2.0.0
should work with GHC 6.12. The "collect2: ld" error message above gives no
meaning to me. Has anyone succeeded installing the Haskell Platform on
CentOS 5.5?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20110318/1732b6a8/attachment.htm>

More information about the Haskell-Cafe mailing list