[Haskell-cafe] Installation of Haskell Platform on CentOS 5.5

Ketil Malde ketil at malde.org
Fri Mar 18 08:23:10 CET 2011

Tristan Ravitch <travitch at cs.wisc.edu> writes:

> The ghc7 binaries are compiled against a newer version of glibc than
> is available on RHEL/CentOS.  It works fine if you compile ghc7 from
> source yourself (you can use 6.12 for that).

Did it?  I tried to do that, but I got errors about needing -fPIC.  I
tried to mess with CFLAGS, but couldn't make it work out.  According to
somebody on #haskell (I apologize for forgetting whom), the problem was
really a too old GCC version.

If I haven't seen further, it is by standing in the footprints of giants

More information about the Haskell-Cafe mailing list