[Haskell-cafe] some problem with Cabal

Daniel Fischer daniel.is.fischer at googlemail.com
Wed Mar 9 01:08:12 CET 2011

On Wednesday 09 March 2011 00:34:39, qiqi wrote:
> The problem is solved! I found out that both global and local package db
> get directory- and process- I unregistered them and
> other caused broken packages in the local package db.

D'oh, I should've seen that.

> Then I
> successfully installed back hmatrix, ghc-mod, happy and etc. It seems
> that xmobar will install directory- again in the local package
> db.

That's not good. And it doesn't seem to do that here:

$ cabal install xmobar --dry-run
Resolving dependencies...
In order, the following would be installed (use -v for more details):

What does

$ cabal install xmobar --dry-run -v3 say for you about directory?

> Did you succeed in installing haddock 2.9?

That was built with the compiler (I built from source), no problems.

$ haddock --version
Haddock version 2.9.2, (c) Simon Marlow 2006
Ported to use the GHC API by David Waern 2006-2008

> Mine got some syntax oriented
> error duing cabal install haddock. But it's fine.

The same as 
http://haskell.org/pipermail/haskell-cafe/2011-March/089902.html ?
I don't know if that's been solved.

More information about the Haskell-Cafe mailing list