[Haskell-cafe] Packages all screwed up

Arnaud Bailly arnaud.oqube at gmail.com
Tue Feb 1 08:16:54 CET 2011

Thanks for your answers.

I did

> cabal upgrade yesod

As for the user/global issue, I think I tried a user install, this is
default isn't it?

Looks like I will have to reinstall everything :-(


On Tue, Feb 1, 2011 at 1:34 AM, Antoine Latter <aslatter at gmail.com> wrote:
> On Mon, Jan 31, 2011 at 4:59 PM, Arnaud Bailly <arnaud.oqube at gmail.com> wrote:
>> Hello,
>> I recently tried to upgrade some package (eg. yesod) and it seems
>> that, in the process, I screwed up my Haskell packages setup.
>> When I am trying to do a simple:
>>> ghc --make Crete1941
> What command(s) did you issue to "upgrade some packages?"
> Were you trying to do a user or global install?
> When ghc loads packages, I've had cases where packages in the user db
> would shadow packages in the global db, causing *other* packages in
> the global db to report as "broken".
> Thanks,
> Antoine

More information about the Haskell-Cafe mailing list