[Haskell-cafe] Compiling and installing glib and gtk+ on Snow Leopard

Mark Spezzano mark.spezzano at chariot.net.au
Sat Oct 23 10:00:52 EDT 2010


I'm trying to install the Leksah IDE and I've run into the problem that it requires glib and gtk+.

Whenever I type 'configure' for glib-2.26.0 everything goes fine.

But when I type 'make' it goes through necessary actions and then suddenly stops halfway through stating the following (annoying) error message:

error: #error GNU libiconv not in use but included iconv.h is from libiconv

What, exactly is happening here? I've compiled libiconv and put it under /usr/bin (so iconv is there). Yet it still complains...I don't get it. I've spend the best part of a day mucking around with this to no avail.

Also: I used to have Leopard installed on my machine and then I upgraded to Snow Leopard--does this mean that I would need to rebuild from scratch most of the packages on the entire system? Could this change from 32-bit to 64-bit be causing an issue?



More information about the Haskell-Cafe mailing list