[Haskell-cafe] Re: Re: Make your Darcs repositories hashed?

Ben Franksen ben.franksen at online.de
Tue Oct 12 19:41:01 EDT 2010

Jason Dagit wrote:
> On Tue, Oct 12, 2010 at 2:02 PM, Ben Franksen
> <ben.franksen at online.de>wrote:
>> One minor but important note: the hashed format is *not* readable with a
>> darcs-1 program:
> Sorry about that.  The support for hashed repos existed long before 2.0
> was released and so I misremembered the hashed support as appearing in a
> 1.x release.
> It looks like you need at least 2.0 to read darcs 1 hashed repos.
> Upgrading to a modern darcs client is advised and is only a 'cabal install
> darcs' away.  I was under the impression that even debian stable has moved
> on to 2.x releases.  How is it that you have a 1.0.9 release candidate
> client still?

Have you ever worked at a public institution? I recommend the
experience... ;-)

Seriously, the server is a debian etch (!) system. Also called "debian
old-stable". Of course I have long since installed newer version of darcs,
but since I am not root there I cannot put it into /usr/local, so I cannot
completely rule out the possibility that other users still use the
ancient /usr/bin/darcs and will now have problems when they darcs get.

I do _not_ expect that this will lead to any serious trouble, as the latest
stable darcs is just a small addition to the PATH away. Still, users should
be warned that darcs-2.x is required.


More information about the Haskell-Cafe mailing list