[Haskell-cafe] Re: Cabal-install is broken

Christian Maeder Christian.Maeder at dfki.de
Tue Nov 23 07:20:34 EST 2010

Am 22.11.2010 23:16, schrieb Permjacov Evgeniy:
> current cabal-install (0.8.2) cannot be compiled with ghc-7.0.1 set of
> boot libraries. It requires cabal 1.8.* wich fails to compile. Does
> anyone worked this out ?

You can re-use your old cabal binary (if you still have it) that was
compiled with ghc-6.

Alternative get cabal-install from
http://darcs.haskell.org/cabal-install/ and adjust the file
cabal-install.cabal (if it did not change meanwhile).



More information about the Haskell-Cafe mailing list