[Haskell-cafe] Cabal-install is broken

Antoine Latter aslatter at gmail.com
Mon Nov 22 17:29:41 EST 2010

On Mon, Nov 22, 2010 at 4:16 PM, Permjacov Evgeniy <permeakra at gmail.com> wrote:
> current cabal-install (0.8.2) cannot be compiled with ghc-7.0.1 set of
> boot libraries. It requires cabal 1.8.* wich fails to compile. Does
> anyone worked this out ?

On some of my development environments I've been using the development
version of cabal-install.

On others, I stick to the Haskell Platform, which does not yet support GHC 7.

It's a real pain to get cabal-install going on GHC 7, as you need to
install all of the dependencies of cabal-install by hand.

The next release of the platform is in January, with an RC is December[1].


[1] http://trac.haskell.org/haskell-platform/wiki/ReleaseTimetable

More information about the Haskell-Cafe mailing list