[Haskell-cafe] Error installing hp2any-graph on Snow Leopard

Mark Spezzano mark.spezzano at chariot.net.au
Tue Nov 9 07:25:56 EST 2010

Hi John

Yes, I finally got it (partly) working. I needed to add the --extra-lib-dirs=<pathname> and --extra-include-dirs=<pathname> flags to point to the necessary libraries.

However, now the hp2any-manager won't install because of (other) dependencies. So I've given up on it for the time being because it's causing me too much trouble. Maybe I'll try again later.

(Strangely it needs _earlier_ versions of cairo and pango and gtk etc, and doesn't recognise that I actually have these installed. But when I do this, other stuff breaks, and I need to reinstall cabal).


On 09/11/2010, at 10:24 PM, John Lato wrote:

> From: Mark Spezzano <mark.spezzano at chariot.net.au>
> Hi,
> I get the following error when doing a 'cabal install hp2any-graph' (the profiling tool)
> Does anyone know why? (I'm running Snow Leopard and I've tried using other flags suggested...but with no success). GLUT is already installed via MacPorts and via cabal.
> Have you tried to build any Haskell programs using GLUT?  Do they work?
> John
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20101109/acf1a6e1/attachment.html

More information about the Haskell-Cafe mailing list