[Haskell-cafe] ANN: Salvia-1.0.0

Ivan Miljenovic ivan.miljenovic at gmail.com
Sun Mar 21 20:04:42 EDT 2010

On 22 March 2010 10:57, Bernie Pope <florbitous at gmail.com> wrote:
> Do you have minumum requirements for GHC? I tried to 'cabal install
> salvia-demo', but with no luck:

Looking at the dependencies listed, they claim that GHC should work
with >= 6.10.1.

> cabal install salvia-demo
> Resolving dependencies...
> cabal: cannot configure syb-with-class-0.6.1. It requires template-haskell
> ==2.4.*
> For the dependency on template-haskell ==2.4.* there are these packages:
> template-haskell- However none of them are available.
> template-haskell- was excluded because template-haskell- was
> selected instead
> template-haskell- was excluded because ghc-6.10.4 requires
> template-haskell ==

Hmmm.... a quick look through the dependencies couldn't reveal what
was pulling in syb-with-class; maybe if you just install
syb-with-class-0.6 first and it will use that instead?

Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com

More information about the Haskell-Cafe mailing list