[Haskell-cafe] Upgrading to Haskell Platform

Jason Dagit dagit at codersbase.com
Sat Mar 13 12:39:16 EST 2010

On Wed, Mar 10, 2010 at 8:50 AM, David Place <d at vidplace.com> wrote:

> Hi:
> I am running GHC 6.10.4 on Mac OSX 10.6.2.   Somehow, I have a broken
> version of Cabal ( installed.

In what was is it broken?  A co-worker of mine had problem recently where
her cabal was giving "Bus error" whenever it tried to use network
functionality (fetch, update, install).  We could see where this was
happening by running something like:
gdb --args cabal install
> run

And we'd see the mangle name of Network.Socket.getSocketOptions at the top
of the stack trace.  dtruss wasn't much help here, but that may have been a
lack of experience with that tool.

The solution for my co-worker was to upgrade to network- then rebuild
HTTP-4000.0.9 against the upgraded network library then rebuild/reinstall
the latest Cabal and cabal-install packages.  This had to be done using
runghc Setup ... instead of cabal.  Whenever she would type 'cabal install'
(even from inside a package's directory) it would try to download from
hackage and give another Bus error.

Does that sound like your problem?

>  In order to fix it, I thought I should just upgrade to the Haskell
> Platform.  Is it necessary to uninstall my current GHC first?  If, so, how?

I don't think you need to uninstall your current GHC.  I tend to have
multiple GHC's installed.  But, you should know that the next Haskell
Platform release is very soon (before the end of the month) and it will
include ghc 6.12.

I hope that helps,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/haskell-cafe/attachments/20100313/53717480/attachment.html

More information about the Haskell-Cafe mailing list