[Haskell-cafe] Upgrading to Haskell Platform

Thomas Hartman tphyahoo at gmail.com
Fri Mar 12 17:43:11 EST 2010

It should not be necessary to uninstall ghc, as hask plat and ghc are
orthogonal by design.
Unless there is some gotcha I am unaware of, not being a mac user.

You are aware that hask plat is beta though, right?

You might be better served simply upgrading your cabal, and waiting
for the all-in-one mac packager to be really shiny.

You can grab cabal here, and after you have unzipped it run the
bootstrap script which also downloads dependencies you might need.


2010/3/10 David Place <d at vidplace.com>:
> Hi:
> I am running GHC 6.10.4 on Mac OSX 10.6.2.   Somehow, I have a broken version of Cabal ( installed.  In order to fix it, I thought I should just upgrade to the Haskell Platform.  Is it necessary to uninstall my current GHC first?  If, so, how?
> Thanks you.
> Cheers,
> David
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe at haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe

More information about the Haskell-Cafe mailing list