[Haskell-cafe] Cabal dependency hell

Marc Weber marco-oweber at gmx.de
Mon Mar 8 09:37:36 EST 2010

Hi Maciej,

that's why I started hack-nix.

You can patch dependencies easily.

However you have to install the Nix package manager.

It also works with lates versions only because the dependency solves is
written in Nix itself.

Which package is causing trouble to you?

We can't expect package maintainers to test everything.
So it must be people like you and me who fixes those changes.

The way to go is make hackage allow changing constraints on the fly
notifying the author that he can update his repository.

This will work in most cases.

Bumping versions because a dependency has changed is bad as well.

This will cause to much overhead (and it dosen't solve the problem
because the old package is still wrong).

Specifying dependencies must be decoupled from bumping versions.

It's because dep specs do depend on the "world" which can change..

At least that's what I think.

If you're interested in Nix and hack-nix I can show you how everything
works using an SSH session.

Marc Weber

More information about the Haskell-Cafe mailing list